Admod's blog

just logs

Booting USB in VMWare — November 24, 2009

Booting USB in VMWare

จดไว้คร่าวๆเกี่ยวกับการบูตพวกอุปกรณ์ที่ไม่ได้รองรับโดยตรงจาก VMWare
ในที่นี้คือ USB ที่ผมเอา ChromeOS ลงไว้

ประเด็นปัญหาของผมคือ ได้รับ ChromeOS ที่ใช้ได้บน USB Flashdrive จาก Makeuseof.com แล้วพอนำไปบูตจริงดันไม่สามารถเปิดอุปกณฺเครือข่าย (ในที่นี้คือ WLan – Intel 2200BG) เลย Login ไม่ได้

แต่ทีนี้คือ ตัว ChromeOS เนี่ย จะามารถเข้าระบบด้วย Account ที่เคย Login ในเครื่องนั้นๆได้ ผมก็เลยหาวิธีให้มัน Login สักครั้ง แล้วจะลองเอาหลับไปบูตจริงๆอีกที

ผมเลยลองไป Google ดูวิธี ก็เจอเว็บนี้เข้า vladan.fr แลดูน่าสนใจ
(และทดลองแล้วใช้ได้!)

Key ของวิธีนี้ก็คือ การไปใช้เครื่องมือตัวนึงของ PloP ที่มีชื่อว่า Bootmanager

คุณสมบัติ

CD/DVD boot without BIOS support
USB boot without BIOS support (UHCI, OHCI and EHCI)

Floppy boot
Different profiles for operating systems
Define up to 16 partitions
No extra partition for the boot manager
Hidden boot, maybe you have a rescue system installed and the user should not see that there is another system installed
Boot countdown
Hide partitions
Password protection for the computer and the boot manager setup
Backup of partition table data
Textmode user interface 80×50
Graphic user interface 640×480, 800×600, 1024×786, 1280×1024
MBR partition table edit
Start of the boot manager from harddisk, floppy, USB, CD, DVD
Starting from Windows boot menu
Starting from LILO, GRUB, Syslinux, Isolinux, Pxelinux (network)
The boot manager is freeware

 

เออ..ที่น่าสนใจก็ตรงที่ Highlight ไว้นั่นแหละ

Continue reading

Advertisements
M9V is back — January 17, 2009

M9V is back

ก่อนอื่นก็ต้องต้องขอขอบคุณบริการจาก Bios-Repair มา ณ ที่นีครับ

เดิมทีที่ทำ Bios เดี้ยงไปโดยการ Flash ไบออสด้วยไฟล์ที่โมใส่ SLIC เอง แล้วปรากฏว่าไฟล์ที่เอาใส่เข้าไปใหม่มันพัง

M9V เลยได้นอนยาวไปครึ่งปี

พยายามหาร้านในพันธุ์ทิพย์และเซียร์ รังสิตแล้วไม่มีร้านไหนสามารถทำได้ (ซึ่งที่จริงมันแค่เป่าเอา Chip ออกมา Flash เข้าไป แล้วเป่าติดคืน)

เมื่อสักก่อนปีใหม่ 1 อาทิตย์ ผมเลยลองติดต่อไปยัง Bios-Repair มา ด้วยอานิสงค์ของ Internet ทำให้ผมสามารถติดต่อกับคนฝั่งยุโรปได้ภายในไม่กี่นาที

ผมทำการติดต่อไป โดยบอกรุ่น Chip ไป
Paul ตอบกลับผมว่า

Hi AdmOd

I have 1 x used 49LF004A 33-4C-WH that i removed from a board i was trying to repair.

I also have new PMC parts i.e pm49FL004T 33VCE in VSOP package

Many thanks for using the service

Regards

Paul Gardner

เป็นครั้งแรกที่ผมได้รับเมล์ตอบกลับแบบนี้ ซึ่งส่วนมากจะบอกว่า ไม่มีอุปกรณ์ หรือเครื่องมือ (ในไทยตอบทั้ง 2)

จากเมล์นี้ทำให้รู้ว่า
– มันเป็น VSOP 32pin
– 49LF004A 33-4C-WH กับ PM49FL004T 33VCE ใช้แทนกันได้ ต่างกันแต่ยี่ห้อ
– ร้านคอมพ์ในไทยส่วนมากเรียก 3,000.- สำหรับบริการนี้

Paul คิดค่าบริการสำหรับ Chip และเขียนโปรแกรมด้วยราคา £12.49 และค่าขนส่งอีก £1.25

เขาค่อนข้างมั่นใจว่าใช้ได้ชัวร์ ซึ่งผมรู้สึกได้

Hi AdmOn

If it doesnt ill eat my hat lol.

ท่าทางจะอยากกินจนพิมพ์ชื่อผมผิด

แต่ผมไม่ถือ เลยสั่งมาแล้วจ่ายผ่าน eBay
และได้รับในอีก 7 วันถัดมา
(ดองอยู่ ไปรษณีย์บางกอกน้อย 3 วัน นับจาก Timestamp หน้าซอง)

ไม่รอช้า ผมทำการติดต่อพี่โจ(1)ทันที

พี่โจรับเครื่องไว้ 1 คืน เนื่องจากวันนี้งานเยอะ และคอมพิวเตอร์ผมฝากไว้ที่ร้าน “เล้ง IT”(2) เครื่องมีปัญหานิดหน่อยเนื่องจากการประกอบผิดวิธี ผมเลยฝากพี่เขาจัดดูแลให้

บ่ายวันต่อมาหลังสอบ GIS ก็ได้รับข่าวดีคือ “เปิดติดแล้ว” วู๊วววว~

 

สรุปค่าซ่อมงานนี้หมดไป
£12.49 + £1.25 + ค่าช่าง 500

1. พี่โจ ช่างบนพันธุ์ทิพย์ชั้น 4 รับซ่อม Notebook ในร้านขายคอมพ์มือ 2 ชื่อร้าน Used อะไรสักอย่าง skill เทพมาก และไม่เคยหน้าบูด
2. ร้านนี้ ส่งคอมพ์ไปสภาพ 90% กลับมาไม่ถึง 80% เช็ดถูอีกยาว

M9V, Bios chip descript — November 23, 2008
M9V is gone — October 10, 2008

M9V is gone

ROM with BIOS

Image via Wikipedia

เหตุเกิดเมื่อหลายเดือนที่แล้ว

ตอนนั้นไปเปิดอ่านในเว็บไซต์ mydigitallife เจอบทความเกี่ยวกับการโมฯ Bios ให้เป็น OEM เวลาติดตั้งวินโดว์จะได้ไม่ต้อง Crack

ด้วยความขี้เกียจและอยากลองเลยจัดการดาวน์โหลดแล้วก็เอา Bios Rom ตัวล่าสุดใส่เข้าไป (ก่อนหน้านั้นก็พยายามจะลองเอา Bios ไปใส่รูป แต่ไม่สำเร็จ)

คืนนั้นเกิดขี้เกียจ เลยโมฯทิ้งไว้แล้วไปนอน

เช้ามาเลยลอง Flash เข้าไปอย่างง่ายดาย แล้วหน้าจอก็ขึ้นให้ Reboot
..เลยตามใจมัน Ctrl + Alt + Del ซะ

“เงียบ…”

มันต้องมีอะไรผิดแปลกไปแน่ๆ reboot อีกทีซิ

“..เงียบ”

เลยทำการถอดแบต ถอดสายชาร์จ ลองบูตจากแบต จาก AC ก็ไม่ติดสักอย่าง

สรุปได้เลยว่า Bios เจอ Bad Flash เข้าไปแล้วแน่ๆ

ลองติดต่อทาง AsusTek แล้วได้ความว่า

ต้องเปลี่ยน Mainboard ครับ

เลยจัดการหาร้านใน Pantip เพื่อทำการซ่อม..

นับเวลารวมถึงปัจจุบันก็ 4 เดือนเห็นจะได้ ที่ยังซ่อมไม่ได้เพราะ

File ที่จะเอามา Flash มันใช้จากเว็บไม่ได้น่ะน้อง ต้องรอรุ่นเดียวกัน(หลง)เข้ามาอย่างเดียว

อืมม… มีร้านไหนรับซ่อมมันซ่อมมันได้ไม๊นะ